RHEL6 and CentOS 6: missing libmcrypt and libmhash in default repository

For God-knows-what reason, the libmcrypt and libmhash aren't included in the default repository for CentOS 6 or Red Hat Enterprise Linux 6. So you'll run into the following when trying to compile PHP.

configure: error: mcrypt.h not found. Please reinstall libmcrypt.

And you can't install it.

# yum install libmcrypt-devel
...
No package libmcrypt-devel available.
Error: Nothing to do

The (only) solution so far: grab the packages from the EPEL repository. Download the RPM (it's same RPM for i386, i686 and x86_64) and install it.

# rpm -ivh “http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm”

And you can install it as "yum install libmcrypt-devel" again. Or libmhash, just the same.

Hi! This is a blog where I write down solutions to some of the problems I've faced when working as a sysadmin/dev. I hope you find the information shown here useful to you. Please use the comments on this blog to give feedback about the content!. I'm @mattiasgeniar on Twitter.

Tagged with: , ,
Posted in linux, php
8 comments on “RHEL6 and CentOS 6: missing libmcrypt and libmhash in default repository
  1. Levent Pinar says:

    Thanks, worked as described

  2. Bryon says:

    A+++ thanks, 10/10

  3. indra says:

    thanks Mattias, you saved my day

  4. Yatin says:

    Updated URL … rpm -ivh “http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm”

  5. Ashwani says:

    Thanks Mattias

  6. Sharl says:

    thx for sharing this point.

Leave a Reply

Your email address will not be published. Required fields are marked *

*

*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>